The current version of the PrestoExperts Messenger requires Windows XP or later. While supporting most browsers, for optimal performance we suggest that you use Internet Explorer, version 7.0 or above.

Unfortunately at this time our PrestoExperts Messenger does not support Mac operating systems; only Windows operating systems are supported.

If you are having issues downloading the PrestoExperts Messengers, please click here to learn more. If you are still having issues, please open a ticket here.